Finally got my spray counter working!

Hi all,

I’ve been having trouble getting my sprays to count since starting on the passiflora formulation.

To be clear, I have the sofi stick from S1 (the original one we used for valerian).

At first I thought I’d maybe received the wrong (s2) refill pods which wouldn’t connect with my stick. But ruled that out after checking to see if the top of my pods were the new style or not. They are not. They are the old style pods.

As we know, with the old style stick you have to really press down hard to get it to register but no matter how hard I pressed, I still could not get it to register my sprays.

Today I disassembled my sofi stick again and took out a tiny little plastic nobby-thing inside the stick and gave that a little bit of a clean and then reassembled it.

And to my surprise, after pressing down very firmly, it started finally registering my sprays!

Not really a magical solution but for some reason taking it apart and putting it back together worked this time around.

So passiflora pod one finished with no sprays recorded, I can finally start recording the data for pod two.

Please see the pictures attached for the element I took out and put back in. Please be aware this is for this of us with the very first sofi stick that might have issues with sprays recording and I hope it might help someone else too.


6 Likes

Have to also be certain the battery is working. Pressing the little round button on the disassembled disc should trigger the green light in the front. If the light is not going on when pressing the black round tiny button, likely need a battery change. This has solved my connection a number of times.

2 Likes