White screen. app crashing

Hi, I was really enjoying the app finding it really useful and had just received my pebble.
Soon after that the aoo stopped functiong :frowning:
The app starts to load and i get the Welcome to sofi splash screen then it just goes to a whitescreen and stops like that.
My phone is a Huawei P40 pro if that helps.

3 Likes

Hi @bobnot

I’ve just posted on the bug fixing report topic about having the same problem.

I wasn’t sure whether to post there or start a new topic like you’ve done. Hopefully @Kaveh and @alexwalkerjones won’t mind if I tag them here and maybe your post could be the topic where people post if they’re having current white screen of death problems?

I’ve had it for about 4 or 5 days. Sometimes happens as soon as I login but usually when I get to to bubbles part of the journal

When it happens straight away I’ve managed to sort it out by clearing the cache in all my apps, uninstalling & reinstalling Sofi and turning my phone on and off. Hopefully that will help you too? It still keeps happening when I get to the bubbles stage but might be different for you

Is your phone Android 10? Mine is and as it’s old I can’t update to Android 11. Don’t know if that’s the problem although I’ve not had any problems until last week and I’ve been doing Sofi for months. Unless there’s been a recent Sofi update that only works with Android 11?

Hopefully we’ll find out what the problem is and can get back to our journaling as normal soon :pray:

6 Likes

Thank you both @bobnot and @Purplepink - I have got this flagged, and the team will shortly be investigating! So sorry that this is occurring for you, and fingers crossed it’ll be a quick fix :sofi_moon: :raised_hands:

5 Likes

Thank you @alexwalkerjones
I’m sorry I can’t journal properly because of this but hopefully it will be sorted soon :pray:

The good news is so far I’ve been able to still register my sprays and do the first part of the journal. The white screen problem happens when it goes to the bubbles page

Thanks again for looking into it :blush:

4 Likes

Thank you @alexwalkerjones I look forward to getting the app up and running. It was really proving to be insightful i took my pebble in with me while i had a surgical procedure. Just holding it reminded me that as frightening as it was it would pass and my cat would be waiting at home.
Begone Anxiety.

6 Likes

Touch wood I think it’s working again! I’ve managed to get past the bubbles without white screen coming :raised_hands:

I hope yours is working again @bobnot?
I’ve found it reassuring too and I love my pebble!

If yours is still not working, in case it helps I uninstalled Sofi, turned my phone off, then reinstalled Sofi. I had to do it several times in the last few days but hopefully all sorted now. I also cleared the cache in all my apps everyday Hope it works for you too :pray:

3 Likes

Hi @bobnot @Calluna - thank you again for your patience while we worked to find the cause of the white screen of death issue!

I heard back from our developers and they suggest - similarly to what you’ve done @Purplepink - to uninstall and reinstall the app, to not log in, but to keep your app open for 5-10 minutes so the code push can occur.

Unfortunately there is no sign that it’ll have worked, but 10 minutes should be plenty. So at that point you can close and re-open the app and it should do the trick. Should either of you find that it didn’t work, please let me know as this may signal a deeper issue :raised_hands: :pray:

3 Likes

@alexwalkerjones @Purplepink My app is working. although it id am now logged out and trying to remember my login.

edit: All working Thank you.

3 Likes

Mine has been fine until yesterday. Started to load then went to black screen with spinning wheel. Had to reboot my phone to get it to work.

5 Likes

Hi @Julesp

I’m sorry I didn’t see your post until now.
I hope it’s working for you now.? I had to play around with my phone a few times over several days but eventually got it sorted. I uninstalled, reinstalled, cleared the cache in all my phone apps, and restarted my phone each time.

I’ve really enjoyed my Sofi journey so far and found it helpful. I hope it’s the same for you :hugs::pray:

4 Likes

I also get that sometimes @Julesp when the app is in need of an update … interesting to see if your problem has been resolved and what version of the sofi app you are on … if you can launch the app you can see this on the top right corner when you touch the “person” icon on the top right ( see below) … also adding @alexwalkerjones so we can follow your progress :pray:

1 Like

It’s 3.3.19 it’s started working again now but it did the same before. I’ll just see how it goes…

1 Like